TufinOS Lifecycle and Build History

Overview

Review the Compatibility Notes prior to upgrading, to determine if there are compatibility issues that may affect your upgrade.

See the Security Advisories page for a complete listing of TufinOS security updates.

The most recent build for each version is marked with in the tables below.

TufinOS 3.x Lifecycle & Build History

Version Build # Release Date

Security Updates

3.81

289282

December 2021

Yes

3.80

285312

December 2021

Yes

3.71

267154

November 2021

Yes

3.70

253044

August 2021

Yes

3.60

246426

August 2021

Yes

3.51

227499

April 2021

Yes

3.50

212687

February 2021

Yes

3.40
pre-installed on Tufin appliances only

192742

December 2020

No

3.30

(No longer available)

188800

September 2020

No

3.20

(No longer available)

181920

August 2020

No

TufinOS 2.x (EOL) Lifecycle & Build Numbers

Version Build # Release Date

Direct Upgrade Path to

Security Updates

2.23

1443 February 2021 N/A No

2.21

(patch for direct upgrade only)

1395

February 2020

2.23

No

2.20

(deprecated due to upgrade issues)

 

 

N/A

No

2.19

(patch for direct upgrade only)

1219

September 2019

2.23, 2.21
See Compatibility Notes

No

2.18

1215

April 2019

2.23, 2.21, 2.19
See Compatibility Notes

No

2.17
(patch for direct upgrade only)

1193

August 2018

2.21, 2.19, 2.18

No

2.16
(patch for direct upgrade only)

1179

May 2018

2.19, 2.18, 2.17

No

2.15

1131

January 2018

2.18, 2.17, 2.16

No

2.14

1089

May 2017

2.17, 2.16, 2.15

No

2.13

1037

November 2016

2.16, 2.15, 2.14

No

2.12

1025

August 2016

2.15, 2.14, 2.13

No

2.11

891

April 2016

2.14, 2.13, 2.12

No

2.10

841

October 2015

2.13, 2.12, 2.11

No

2.9

(See Release Notes)

798
791

August 2015
June 2015

2.12, 2.11, 2.10

No

2.8

753

April 2015

2.11, 2.10, 2.9

No

2.7

673

December 2014

2.10, 2.9, 2.8

No

2.6

659

August 2014

2.8, 2.7

No

2.5

625

May 2014

2.8, 2.7, 2.6

No

2.4

579

February 2014

2.7, 2.6, 2.5

No

2.3

539

December 2013

 

No

2.2

480

August 2013

 

No

2.1

452

June 2013

 

No

TufinOS 3.x Supported Upgrade Paths

Target Version

Available as

Direct Upgrade Path From

Supported Aurora

Supported Classic

3.81

Upgrade image

3.80

3.71

3.70

3.60

R22-1:
PRC1.0.0
R21-3:
PHF2.0.0, PHF1.2.0, PHF1.1.0, PHF1.0.0, PGA.1.0, PGA.0.0, PRC1.0.0
R21-2:
PHF2.0.0, PHF1.0.0, PGA.2.0.0, PGA.2.0.0, PGA.0.0
R21-1:
PHF1.1, PHF1, PGA, PRC1
R21-3:
HF2.1, HF2, HF1.1, HF1, GA, RC1
R21-2:
HF4, HF3, HF2, HF1.5
R21-1:
HF4, HF3.2

3.80

Upgrade image

ISO for VMware

USB image for Tufin appliances

3.71

3.70

3.60

R22-1:
PRC1.0.0
R21-3:
PHF2.0.0, PHF1.2.0, PHF1.1.0, PHF1.0.0, PGA.1.0, PGA.0.0, PRC1.0.0
R21-2:
PHF2.0.0, PHF1.0.0, PGA.2.0., PGA.1.0, PGA.0.0
R21-1:
PHF1.1, PHF1, PGA, PRC1
R21-3:
HF2.1, HF2, HF1.1, HF1, GA, RC1
R21-2:
HF4, HF3, HF2, HF1.5
R21-1:
HF4, HF3.2

3.71

Upgrade image

3.70

3.60

3.51

3.50

R22-1:
PRC1.0.0
R21-3:
PHF2.0.0, PHF1.2.0, PHF1.1.0, PHF1.0.0, PGA.1.0, PGA.0.0, PRC1.0.0
R21-2:
PHF2.0.0, PHF1.0.0, PGA.2.0, PGA.1.0, PGA.0.0
R21-1:
PHF1.1, PHF1, PGA, PRC1
R21-3:
HF2.1, HF2, HF1.1, HF1, GA, RC1
R21-2:
HF4, HF3, HF2, HF1.5
R21-1:
HF4, HF3.2

3.70

Upgrade image

3.60

3.51

3.50

R22-1:
PRC1.0.0
R21-3:
PHF2.0.0, PHF1.2.0, PHF1.1.0, PHF1.0.0, PGA.1.0, PGA.0.0, PRC1.0.0
R21-2:
PHF2.0.0, PHF1.0.0, PGA.2.0, PGA.1.0, PGA.0.0
R21-1:
PHF1.1, PHF1, PGA, PRC1
R20-2:
PGA, PRC1
R21-2:
HF1.4, HF1.3, HF1.2, HF1.1, HF1, GA, RC1
R21-1:
HF3.1, HF3, HF2.1, HF2, HF1.2, HF1.1, HF1, GA, RC1
R20-2:
HF3, HF2.1, HF2, HF1, RC1

3.60

Upgrade image

ISO for VMware

USB image for Tufin appliances

3.51

3.50

3.30

R22-1:
PRC1.0.0
R21-3:
PHF2.0.0, PHF1.2.0, PHF1.1.0, PHF1.0.0, PGA.1.0, PGA.0.0, PRC1.0.0
R21-2:
PHF2.0.0, PHF1.0.0, PGA.2.0, PGA.1.0, PGA.0.0
R21-1:
PHF1.1, PHF1, PGA, PRC1
R20-2:
PGA, PRC1
R21-2:
HF1.4, HF1.3, HF1.2, HF1.1, HF1, GA, RC1
R21-1:
HF3.1, HF3, HF2.1, HF2, HF1.2, HF1.1, HF1, GA, RC1
R20-2:
HF3, HF2.1, HF2, HF1, RC1

3.51

ISO for VMware

3.50

3.30

R21-2:
PHF1, PGA.2, PGA.1, PGA
R21-1:
PHF1.1, PHF1, PGA, PRC1
R20-2:
PGA, PRC1

R21-2: HF1.4, HF1.3, HF1.2, HF1.1, HF1, GA, RC1

R21-1: HF3.1, HF3, HF2.1, HF2, HF1.2, HF1.1, HF1, GA, RC1

R20-2: HF3, HF2.1, HF2, HF1, RC1

3.50

Upgrade image

ISO for VMware

USB image for Tufin appliances

3.30

3.20

R21-2:
PHF1, PGA.2, PGA.1, PGA
R21-1:
PHF1.1, PHF1, PGA, PRC1
R20-2:
PGA, PRC1
R21-2:
HF1.4, HF1.3, HF1.2, HF1.1, HF1, GA, RC1
R21-1:
HF3.1, HF3, HF2.1, HF2, HF1.2, HF1.1, HF1, GA, RC1
R20-2:
HF3, HF2.1, HF2, HF1, RC1

3.30

ISO for VMware

3.20

R21-1:
PHF1.1, PHF1, PGA, PRC1
R20-2:
PGA, PRC1
R21-1:
HF3.1, HF3, HF2.1, HF2, HF1.2, HF1.1, HF1, GA, RC1
R20-2:
HF3, HF2.1, HF2, HF1, RC1

 

3.20

USB image for Tufin appliances

 

R20-2:
PGA, PRC1
R20-2:
HF3, HF2.1, HF2, HF1, RC1

TufinOS 2.x (EOL) Supported Upgrade Paths

Target Version

Direct Upgrade Path From

Supported Classic

2.23

2.21

R20-1:
HF5, HF4.2, HF4.1, HF4, HF3, HF2.1, HF2, HF1.1, HF1, GA, RC1
R19-3:
HF4, HF3, HF2, HF1, GA.1, GA, RC2, RC1
R19-2:
HF4.1, HF4, HF3, HF2.1, HF2, HF1, GA.1, GA
2.21

2.19

2.18

R20-1:
HF5, HF4.2, HF4.1, HF4, HF3, HF2.1, HF2, HF1.1, HF1, GA, RC1
R19-3:
HF4, HF3, HF2, HF1, GA.1, GA, RC2, RC1
R19-2:
HF4.1, HF4, HF3, HF2.1, HF2, HF1, GA.1, GA
2.19

2.18

2.17

R19-3:
HF4, HF3, HF2, HF1, GA.1, GA, RC2, RC1
R19-2:
HF4.1, HF4, HF3, HF2.1, HF2, HF1, GA.1, GA
R19-1:
HF3, HF2, HF1.2, HF1.1, HF1, GA
R18-3:
HF3.2, HF3.1, HF3, HF2.1, HF2, HF1.2, HF1.1, HF1, GA
R18-2:
HF3, HF2, HF1.2, HF1.1, HF1, GA.1, GA
R18-1:
HF3.2, HF3.1, HF3, HF2, HF1, GA.1, GA

Compatibility Notes

TufinOS 3.81

See the TufinOS 3.81 Compatibility and Requirements page

TufinOS 3.80

See the TufinOS 3.80 Compatibility and Requirements page

TufinOS 3.71

See the TufinOS 3.71 Compatibility and Requirements page

TufinOS 3.70

TufinOS 3.70 is available as a direct upgrade only.

  • Installing TOS for the first time on a server running TufinOS 3.70 or above requires these versions of TOS:

    • R21-2
    • R21-1
    • R20-2
  • Upgrading lower versions of TOS before migrating to TufinOS 3.70: The specific path to TufinOS 3.70 depends on both the TOS and TufinOS version you are currently running.

    • For TOS 20-2 and above running on TufinOS 3.30 and above, you can migrate to TufinOS 3.60, and then to TufinOS 3.70.

    • For TOS R19-3 and R20-1 with PostgreSQL 11 running on TufinOS 2.21, follow the Assisted Upgrade procedure in the Customer Portal to migrate to TufinOS 3.60, and TOS R20-2 and above. From TufinOS 3.60, you can then migrate to 3.70.

    • For lower versions of TOS or TufinOS, first upgrade to TOS R19-3 or R20-1, PostgreSQL 11 and TufinOS 2.21, and then migrate to TufinOS 3.60 and TOS R20-2/R21-1. From TufinOS 3.60, you can then migrate to 3.70.
      See Upgrading to PostgreSQL 11 on TufinOS for full details.

TufinOS 3.60

TufinOS 3.60 for TOS is available as a standalone install, and as a patch for direct upgrade.

  • Installing TOS for the first time on a server running TufinOS 3.60 or above requires these versions of TOS:

    • R21-2
    • R21-1
    • R20-2
  • Upgrading lower versions of TOS before migrating to TufinOS 3.60: The specific path to TufinOS 3.60 depends on both the TOS and TufinOS version you are currently running.

    • For TOS 20-2 and above running on TufinOS 3.30 and above, you can migrate to TufinOS 3.60, and TOS R21-1 or TOS2 R21-2 directly.

    • For TOS R19-3 and R20-1 with PostgreSQL 11 running on TufinOS 2.21, follow the Assisted Upgrade procedure in the Customer Portal to migrate to TufinOS 3.60, and TOS R20-2 and above

    • For lower versions of TOS or TufinOS, first upgrade to TOS R19-3 or R20-1, PostgreSQL 11 and TufinOS 2.21, and then migrate to TufinOS 3.51 and TOS R20-2/R21-1 See Upgrading to PostgreSQL 11 on TufinOS for full details.

TufinOS 3.51

TufinOS 3.51 for TOS Classic is available as a standalone install for VMware.

  • Installing TOS for the first time on a server running a clean install of TufinOS 3.51 or above requires these versions of TOS:

    • R21-1
    • R20-2
  • Upgrading lower versions of TOS before migrating to TufinOS 3.51: The specific migration path to TufinOS 3.51 depends on both the TOS and TufinOS version you are currently running.

    • For TOS 20-2 and above running on TufinOS 3.30 and above, you can migrate to TufinOS 3.51, and TOS R21-1 or R21-2 directly.

    • For TOS R19-3 and R20-1 with PostgreSQL 11 running on TufinOS 2.21, follow the new Assisted Upgrade procedure in the Customer Portal to migrate to TufinOS 3.51, and TOS R20-2 and above.

    • For lower versions of TOS or TufinOS, first upgrade to TOS R19-3 or R20-1, PostgreSQL 11 and TufinOS 2.21, and then migrate to TufinOS 3.51 and TOS R20-2/R21-1 See Upgrading to PostgreSQL 11 on TufinOS for full details.

TufinOS 3.50

TufinOS 3.50 for TOS is available as a standalone install, and as a patch for direct upgrade.

  • Installing TOS for the first time on a server running a clean install of TufinOS 3.50 or above requires these versions of TOS:

    • R21-1
    • R20-2
  • Upgrading lower versions of TOS before migrating to TufinOS 3.50: The specific migration path to TufinOS 3.50 depends on both the TOS and TufinOS version you are currently running.

    • For TOS 20-2 and above running on TufinOS 3.30 or TufinOS3.40, you can migrate to TufinOS 3.50, and TOS R21-1 or TOS2 R21-1 directly.

    • For TOS R19-3 and R20-1 with PostgreSQL 11 running on TufinOS 2.21, follow the new Assisted Upgrade procedure in the Customer Portal to migrate to TufinOS 3.50, and TOS R20-2/R21-1.

    • For lower versions of TOS or TufinOS, first upgrade to TOS R19-3 or R20-1, PostgreSQL 11 and TufinOS 2.21, and then migrate to TufinOS 3.50 and TOS R20-2/R21-1. See Upgrading to PostgreSQL 11 on TufinOS for full details.

  • If upgrading from TufinOS 3.10, you will need to install a pre-upgrade patch. Later versions of TufinOS 3 do not require the pre-upgrade patch.

TufinOS 3.40

TufinOS 3.40 for TOS comes preinstalled on Tufin appliances only, and is not available as an upgrade or as a standalone install.

TufinOS 3.30

TufinOS 3.30 for TOS is available as a standalone install.

  • Installing TOS for the first time on a server running a clean install of TufinOS 3.30 or above is supported for TOS R20-2 

  • Upgrading lower versions of TOS before migrating to TufinOS 3.20: The specific migration path to TufinOS 3.30 depends on both the TOS and TufinOS version you are currently running.

    • For TOS R19-3 and R20-1 with PostgreSQL 11 running on TufinOS 2.21, you can migrate to TufinOS 3.30 and TOS R20-2 directly.

    • For lower versions of TOS or TufinOS, first upgrade to TOS R19-3 or R20-1, PostgreSQL 11 and TufinOS 2.21, and then migrate to TufinOS 3.30 and TOS R20-2. See Upgrading to PostgreSQL 11 on TufinOS for full details.

TufinOS 2.23

TufinOS 2.23 can run Tufin Orchestration Suite R20-1 and below only.

TufinOS 2.22

TufinOS 2.22 can run Tufin Orchestration Suite R20-1 and below only.

TufinOS 2.21

  • TufinOS 2.21 is available as a patch for direct upgrade, and is not available as a standalone install.

  • Tufin is migrating Tufin Orchestration Suite to use PostgreSQL 11, because PostgreSQL 9.4 reached its end of life (EOL) in February 2020. The TufinOS upgrade will install PostgreSQL 11. The specific upgrade path you require to migrate to PostgreSQL 11 is dependent on both the TOS and TufinOS version you are currently running. See Upgrading to PostgreSQL 11 on TufinOS for your specific upgrade path.

  • The TOS backup and restore commands are not affected by the migration to PostgreSQL 11. A TOS backup can be restored to a different server running the matching version of TOS, regardless of the version of TufinOS. For example, a backup of (TOS R19-3 HF3, TufinOS 2.19) can be restored to a server running (TOS R19-3 HF3, TufinOS 2.21).

TufinOS 2.19

  • TufinOS 2.19 is available as a patch for direct upgrade, and is not available as a standalone install.

  • For any version of TOS, TOS backups that were created on a server running TufinOS 2.17 or above cannot be restored to a server running TufinOS 2.16 or below, due to Postgres version compatibility issues. Restores fail because PostgreSQL implemented security fixes in PostgreSQL version 9.4.17 that are not backward compatible with previous minor versions.

TufinOS 2.18

For any version of TOS, TOS backups that were created on a server running TufinOS 2.17 or above cannot be restored to a server running TufinOS 2.16 or below, due to Postgres version compatibility issues. Restores fail because PostgreSQL implemented security fixes in PostgreSQL version 9.4.17 that are not backward compatible with previous minor versions.

TufinOS 2.17

  • TufinOS 2.17 is available as a patch for direct upgrade, and is not available as a standalone install.

  • For any version of TOS, TOS backups that were created on a server running TufinOS 2.17 or above cannot be restored to a server running TufinOS 2.16 or below, due to Postgres version compatibility issues. Restores fail because PostgreSQL implemented security fixes in PostgreSQL version 9.4.17 that are not backward compatible with previous minor versions.

TufinOS 2.16

TufinOS 2.16 is available as a patch for direct upgrade, and is not available as a standalone install.

TufinOS 2.15

Installing TOS for the first time on a server running a clean install of TufinOS 2.15 or above requires:

  • TOS 18-1 or above

    or

  • Install the MongoDB upgrade (see Upgrading MongoDB) and then one of the following TOS versions:

      R17-3 GA or above

      R17-2 HF2.2 or above

      R17-1 HF4.1 or above

      R16-4 HF5.1 or above

Upgrading or installing TOS on a server after you have upgraded the server to TufinOS 2.15 or above, requires one of the following TOS versions:

    R17-3 GA or above

    R17-2 HF2.2 or above

    R17-1 HF4.1 or above

    R16-4 HF5.1 or above

If you are running TOS R16-3 or below you must first upgrade TOS to the desired version using the latest hotfix available, and then upgrade TufinOS.

TufinOS 2.13

For TufinOS 2.13 and above (and RHEL 6.x, CentOS 6.x), to determine if you need to manually install sTunnel on TOS 16-4 and above, see sTunnel Patch Installation Instructions.

TufinOS Lifecycle Policy

Tufin’s Products Support Lifecycle policy outlines the product support guidelines for a product’s lifecycle. The objective of this policy is to standardize and normalize product lifecycle practices, thereby enabling Tufin customers to make more informed purchase, support and upgrade decisions. All Tufin products are covered by this policy. Customers who are operating Tufin products under a valid Support & Maintenance Agreement are entitled to the benefits associated with this policy. For more details regarding the product lifecycle policy, see Tufin Product Lifecycle Policy.

TufinOS 1.x

TufinOS 1.x has reached its "end of life" (EOL). See the TufinOS 1.x archive for additional details.